Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-3564

Default values not recognized In the Locations --> "Manage Layout"

    XMLWordPrintable

    Details

    • Complexity:
      Medium
    • Sprint:
      OpenMRS Platform 1.11 Sprint 1

      Description

      We have the following in the address layout :

         <elementDefaults class="properties">
          <property name="country" value="India"/>
          <property name="stateProvince" value="West Bengal"/>
         </elementDefaults>
      

      We were expecting that when creating a new patient/person, the Country will be defaulted to "India" , but it shows up empty.

      We tried the same in the openmrs demo and there it is

            <elementDefaults class="properties">
             <property name="country" value="Kenya"/>
            </elementDefaults>
      

      But Kenya doesn't shows up in the country field as default.

      After saving the patient also the country is not defaulted to Kenya.

      Obviously workaround exists, that is manually typing in the entry but it can cause manual data entry error and may cause problem in cohort queries.

        Attachments

          Activity

            People

            Assignee:
            jkondrat Jakub Kondrat [X] (Inactive)
            Reporter:
            missionarogya Manish Das [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 3 hours Original Estimate - 3 hours
                3h
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 day, 1 hour
                1d 1h