Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-1598

Allow admin to deploy a module bundle containing all dependencies

    XMLWordPrintable

    Details

    • Type: Epic
    • Status: Ready for Work
    • Priority: Should
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Module Engine
    • Labels:
    • Complexity:
      High

      Description

      Story Points: 20

      Epic Story: We should consider adding support for deploying bundled modules. For example, the reporting module contains two dependencies at the moment. We should be able to build/distribute a reporting module bundle that contains the necessary dependencies and has been tested. Otherwise, administrators are left to decide which versions of a module to use. We will likely alleviate this problem by supporting module version ranges. However, that doesn't really solve the problem of distributing "stable" module releases.

      As a first pass, we should document "bundled" versions on the module's wiki page. For instance, when we release the next version of the reporting module, it should include tested versions for dependencies.

      • reporting v0.4.0.1
      • serialization 0.2.1
      • htmlwidgets 1.5.3

      Behaviors:

      • TBD

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              jmiranda Justin Miranda [X] (Inactive)
              Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated: