Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-1594

Wildcard * not working properly in require_version tag of module config.xml

    Details

    • Complexity:
      Low

      Description

      I run OMRS 1.6 and in my module config of the module I wrote and was going to import, I put <require_version>1.5.*</require_version> as described on http://openmrs.org/wiki/Module_Config_File

      I get the following error message when installing the module:

      Error while trying to start module
      Module requires at least version '1.5.*'. Current code version is only '1.6.0.12436' Module: Database Backup Module

      which doesn't make sense, because 1.6 is higher than 1.5.*

      It only works correct when I enter <require_version>1.5</require_version> in my module config, without the * wildcard.

        Attachments

          Activity

            People

            • Assignee:
              luzhuangwei Zhuangwei Lu
              Reporter:
              mathias.lin Mathias Lin
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: