Currently, when adding/editing a patient identifier, two separate tags used for the identifier and the identifier location, ie:
These should really be combined into a single field, because the identifierLocation means little outside of the context of an identifier. For instance, suppose you collecting two identifiers on a single form. There would be no way to link the appropriate identifierLocation widget with the appropriate identifier widget.
I'd propose getting rid of the field="identifier" although and instead do identifier, identifier type & identifier location via a single field, like so:
<patient field="identifier" showLocationWidget="true"/>