Uploaded image for project: 'Android Client'
  1. Android Client
  2. AC-466

Update Android plugin for Gradle and other libraries

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: TBD
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Complexity:
      Low

      Description

      These need updating:

      • The Gradle plugin should be updated from 3.0.1 to 3.1.3 (the latest stable version).
      • After updating Gradle plugin, we can remove buildToolsVersion as we no longer need to specify it.
      • Kotlin: fromĀ 1.2.20 to 1.2.50
      • We can use implementation instead of the deprecated compile call. In the same way, testCompile would be testImplementation, etc.
      • Support libraries from 27.0.2 to 27.1.1

      After that, CI (.yml) files also need to be changed slightly.

        Attachments

          Activity

            People

            Assignee:
            f4ww4z Fawwaz Yusran [X] (Inactive)
            Reporter:
            f4ww4z Fawwaz Yusran [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 hour
                1h
                Remaining:
                Time Spent - 30 minutes Remaining Estimate - 30 minutes
                30m
                Logged:
                Time Spent - 30 minutes Remaining Estimate - 30 minutes
                30m